~ajpaon

~ajpaon/public-inbox

Last active 1 year, 2 months ago
View more

Recent activity

[PATCH mrsh] Add information to README for LSP users. 1 year, 2 months ago

From Andrew Paon to ~emersion/mrsh-dev

This command generates a file called `compile_commands.json`, which I
added to gitignore. Also ignored `.cache/clangd`, which gets populated
when I run my editor
---

It took me some time to figure out how to make LSP happy in this repo;
hopefully this information is helpful to others.

 .gitignore |  2 ++
 README.md  | 10 ++++++++++
 2 files changed, 12 insertions(+)

diff --git a/.gitignore b/.gitignore
index f269464..0bfc1a1 100644
[message trimmed]

[PATCH mrsh] Move $(LIBS) to end of compile command 1 year, 2 months ago

From Andrew Paon to ~emersion/mrsh-dev

Without this change, when I run `make` it fails with this error (edited
for clarity):

```
ld: frontend/readline.o: in function `sigint_handler':
mrsh/frontend/readline.c:33: undefined reference to `rl_on_new_line'
ld: mrsh/frontend/readline.c:34: undefined reference to `rl_replace_line'
ld: mrsh/frontend/readline.c:35: undefined reference to `rl_redisplay'
ld: frontend/readline.o: in function `interactive_init':
ld: mrsh/frontend/readline.c:53: undefined reference to `read_history'
ld: frontend/readline.o: in function `interactive_next':
ld: mrsh/frontend/readline.c:74: undefined reference to `add_history'
ld: mrsh/frontend/readline.c:76: undefined reference to `write_history'
collect2: error: ld returned 1 exit status
[message trimmed]

[PATCH] Fix markdown link typo: [] -> () 1 year, 2 months ago

From Andrew Paon to ~raiguard/public-inbox

---
Hi there! I noticed this typo while browsing projects on sr.ht. I hope
you don't mind the little patch; it's mostly an excuse to practice with
git-send-email :)

 README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/README.md b/README.md
index 75ec897..4604267 100644
--- a/README.md
+++ b/README.md
@@ -12,7 +12,7 @@ fmm download Krastorio2
fmm sync-file ~/downloads/cool-save-file.zip
[message trimmed]