~autumnull

https://tranarchy.fish/~autumn/

Bonkers Transexual Pseudo-Hacker.

~autumnull/haredo

Last active 3 months ago

~autumnull/haredo-devel

Last active 3 months ago

~autumnull/treecat-dev

Last active 7 months ago
View more

Recent activity

[PATCH harec] type_store: allow unbounded arrays with undefined member size 4 days ago

From Autumn! to ~sircmpwn/hare-dev

Signed-off-by: Autumn! <autumnull@posteo.net>
---
 src/type_store.c   | 12 ++++++------
 tests/01-arrays.ha |  6 +++---
 2 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/src/type_store.c b/src/type_store.c
index bbc723c..fa97802 100644
--- a/src/type_store.c
+++ b/src/type_store.c
@@ -762,17 +762,17 @@ type_init_from_atype(struct type_store *store,
			*type = builtin_type_error;
			return (struct dimensions){0};
		}
[message trimmed]

Re: [RFC v1] Addition of a vector type 7 days ago

From Autumn! to ~sircmpwn/hare-rfc

On 9/14/23 20:50, Sebastian wrote:
> On Thu Sep 14, 2023 at 5:26 AM EDT, Autumn! wrote:
>>> 	let c: [;]int = a[;0]; // vector: length 0, capacity 8
>> perhaps better notation:
>>
>> 	let c: [;]int = a[..0; 8];
>> 	let c: [;]int = a[..0; _]; // equivalent
>>
>> just use a slicing expression with a capacity afterward, where using '_'
>> as the capacity sets it to the maximum, somewhat similar to [_] in array
>> sizes. this underscore syntax is maybe not entirely necessary though,
>> since here you could just write
>>
>> 	let c: [;]int = a[..0; len(a)];

Re: [PATCH hare] replace scripts/gen-stdlib with cmd/genbootstrap 7 days ago

From Autumn! to ~sircmpwn/hare-dev

>>> - it'd be nice to recompile everything automatically when harec -v
>>>     changes, but i'm not sure how to do that in make
>> have a file that contains the output of harec -v in .cache, have every
>> .ssa/.td file depend on it, and do something similar to the .td method
>> to change the file's mtime if it changes?
> 
> seb implemented this but it sucked, since it needed to update harec -v
> before doing anything else. what he did was a start: target updated it a
> d which all and check depended on, then they ran @$(MAKE) all (or
> @$(MAKE) $(BINOUT)/hare in make check) in the target itself, but this
> broke make check since it couldn't dedupe the job queue between the two
> recursive make instancesseems like this paragraph got kinda mangled but what's so bad about 
running harec -v first when that's the thing you want to check if it's 
changed?

Re: [RFC v1] Addition of a vector type 7 days ago

From Autumn! to ~sircmpwn/hare-rfc

> 	let c: [;]int = a[;0]; // vector: length 0, capacity 8
perhaps better notation:

	let c: [;]int = a[..0; 8];
	let c: [;]int = a[..0; _]; // equivalent

just use a slicing expression with a capacity afterward, where using '_' 
as the capacity sets it to the maximum, somewhat similar to [_] in array 
sizes. this underscore syntax is maybe not entirely necessary though, 
since here you could just write

	let c: [;]int = a[..0; len(a)];

~Autumn

Re: [PATCH hare] replace scripts/gen-stdlib with cmd/genbootstrap 7 days ago

From Autumn! to ~sircmpwn/hare-dev

> gen-stdlib, but it's worth noting that it may make sense to replace make
> with ninja here
-1 to ninja -- if the idea is speed, i don't think it's physically 
possible to squeeze a meaningfully faster build out of this, and part of 
the reason for using Make is that it's ubiquitous.

> - it'd be nice to recompile everything automatically when harec -v
>    changes, but i'm not sure how to do that in make
have a file that contains the output of harec -v in .cache, have every 
.ssa/.td file depend on it, and do something similar to the .td method 
to change the file's mtime if it changes?

> +- bootstrap: |
> +    cd hare

[PATCH hare-wayland 2/2] scanner: generate doc comments 8 days ago

From Autumn! to ~sircmpwn/hare-dev

Signed-off-by: Autumn! <autumnull@posteo.net>
---
future work: adapt identifiers from wl_thing to [[thing]]
 cmd/scanner/main.ha | 46 ++++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 45 insertions(+), 1 deletion(-)

diff --git a/cmd/scanner/main.ha b/cmd/scanner/main.ha
index e744148..a5ec649 100644
--- a/cmd/scanner/main.ha
+++ b/cmd/scanner/main.ha
@@ -102,6 +102,7 @@ use wayland;

// interface function
def interface_src: str = `
[message trimmed]

[PATCH hare-wayland 1/2] scanner: rename format to formaterr 8 days ago

From Autumn! to ~sircmpwn/hare-dev

Signed-off-by: Autumn! <autumnull@posteo.net>
---
 wayland/scanner/scan.ha | 74 ++++++++++++++++++++---------------------
 1 file changed, 37 insertions(+), 37 deletions(-)

diff --git a/wayland/scanner/scan.ha b/wayland/scanner/scan.ha
index e51f760..1bc827d 100644
--- a/wayland/scanner/scan.ha
+++ b/wayland/scanner/scan.ha
@@ -6,14 +6,14 @@ use strconv;
use strings;

// Returned when scanning an XML file which does not meet the expected schema.
export type format = !void;
[message trimmed]

[PATCH hare-wayland] Add contributing section to README.md 8 days ago

From Autumn! to ~sircmpwn/hare-dev

Signed-off-by: Autumn! <autumnull@posteo.net>
---
 README.md | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/README.md b/README.md
index abe8987..6c8b233 100644
--- a/README.md
+++ b/README.md
@@ -7,3 +7,10 @@ Run `make generate` to build the code generator and generate the Hare code.

Then, `hare run` runs a simple Wayland client that outputs all globals that are
available on the local Wayland server.

[message trimmed]

Re: [PATCH hare] all: Rename *_{finish,free} to {finish,free}_* 11 days ago

From Autumn! to ~sircmpwn/hare-dev

On 9/9/23 10:23, Drew DeVault wrote:
> Hm, I don't like this at all. subject_verb is generally much more
> preferrable imho for these functions. NACK
so, the main issue here is grammatical, in that the noun in all these 
function names is the object not the subject -- i.e. it's "free the 
strings" not "the strings free".

that said, i've been writing C bindings for the last little while and 
have come to appreciate the way that the main object of the function is 
written at the start, since then methods for a certain object are all 
named as module_object_* (or module::object_* for hare).

so i think the naming convention should be changed to not say anything 
about subjects or objects, and instead just say something like "all the

[PATCH hare] add -j2 to .builds for hare 13 days ago

From Autumn! to ~sircmpwn/hare-dev

Signed-off-by: Autumn! <autumnull@posteo.net>
---
 .builds/alpine.yml  | 4 ++--
 .builds/freebsd.yml | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/.builds/alpine.yml b/.builds/alpine.yml
index dc0dd0cb..0dec402f 100644
--- a/.builds/alpine.yml
+++ b/.builds/alpine.yml
@@ -30,14 +30,14 @@ tasks:
- hare: |
    cd hare
    cp config.example.mk config.mk
[message trimmed]