~cadence/breezewiki-discuss

1

Images opening in lightbox reference missing files

Details
Message ID
<AS8P193MB223835197E39BCF2F3088414C4699@AS8P193MB2238.EURP193.PROD.OUTLOOK.COM>
DKIM signature
missing
Download raw message
Images that on Fandom.com open in a lightbox lead to an error page that reads:

Exception raised in Racket code at response generation time:
string::2: bytes->jsexpr: bad input starting #"You are not allowed to access this resource "
  context...:
   /home/cadence/racket/collects/syntax/readerr.rkt:15:2: -raise-read-error
   /home/cadence/racket/collects/racket/contract/private/arrow-higher-order.rkt:375:33
   /home/cadence/breezewiki/lib/thread-utils.rkt:28:20

The links that fail are in the format "breezewiki.com/[wiki name]/wiki/File:[file name].[type]" instead of a "static.wikia.nocookie.net" format, whether or not they include a revision number.

I mostly encounter this error on wikis with Gallery pages. 
Latest page I ran into this with was https://breezewiki.com/aceattorney/wiki/Apollo_Justice_-_Image_Gallery

Same error occurs when trying to access "[wiki name]/wiki/Category:[name]" pages.

Bug occurs the same way every time.

(Second attempt at a bug report b/c I forgot to turn on rich text editor the first time, my bad)
Details
Message ID
<8eb09527-eebc-4fe3-9ebd-cf66bc212958@disroot.org>
In-Reply-To
<AS8P193MB223835197E39BCF2F3088414C4699@AS8P193MB2238.EURP193.PROD.OUTLOOK.COM> (view parent)
DKIM signature
missing
Download raw message
Thank you for the very well detailed bug report!!
This issue will be solved along with category pages being broken, since 
it's the same change to fix both.
File pages should still be available on other instances such as 
antifandom.com.
https://todo.sr.ht/~cadence/breezewiki-todo
Reply to thread Export thread (mbox)