~captainepoch/husky-devel

2

Allow composing formatted posts on Glitch instances

Luna Dragofelis <lunadragofelis@gmail.com>
Details
Message ID
<CANZUzm==SCn7gQTngDpLPBfxrDVw99Dbz4a3OaNUH-4R2hRyCQ@mail.gmail.com>
DKIM signature
pass
Download raw message
Glitch (Mastodon fork) supports formatted posts with HTML and
Markdown, unlike standard Mastodon.

On older versions of Husky, it was possible to compose posts with HTML
and Markdown, but now I don't see the option anymore (while using
instance embracing.space).
It seems like Husky is checking if the instance is Mastodon, and then
disables formatting, but doesn't check if it's Glitch which would
support it.

Kind regards, Luna Saphira Dragofelis
Details
Message ID
<20220617150815.haae4wiuifgd7uzr@MacBook-Pro-de-Adolfo.local>
In-Reply-To
<CANZUzm==SCn7gQTngDpLPBfxrDVw99Dbz4a3OaNUH-4R2hRyCQ@mail.gmail.com> (view parent)
DKIM signature
pass
Download raw message
>Glitch (Mastodon fork) supports formatted posts with HTML and
>Markdown, unlike standard Mastodon.

Yeah, like Pleroma.

>On older versions of Husky, it was possible to compose posts with HTML
>and Markdown, but now I don't see the option anymore (while using
>instance embracing.space).

If you go to the M icon while composing a status and do a long press,
you should see a menu with all the formating options the instance
allows.

>It seems like Husky is checking if the instance is Mastodon, and then
>disables formatting, but doesn't check if it's Glitch which would
>support it.

Would you provide me the domain of the instance to test it?

Thank you for the email!
Details
Message ID
<20220618063841.fzo7w4paiwdiy2u4@MacBook-Pro-de-Adolfo.local>
In-Reply-To
<20220617150815.haae4wiuifgd7uzr@MacBook-Pro-de-Adolfo.local> (view parent)
DKIM signature
pass
Download raw message
I'll reply to my own message citing yours. Please, press "Reply All" and
check that the subject of the email is the proper one, otherwise it'll
create new threads in the mailists.

>When composing a post while logged in on embracing.space, the M icon
>does not show. To be able to test directly on this instance, you'd
>need an account. If you want one, consider asking
>@IngaLovinde@embracing.space.
>
>On Pleroma instances (fedi.absturztau.be and obese.cat) the icon does
>work as you described.

Noted, I'll ask for an account there to give this a try and see fi I can
fix it.

Thank you for the report!
Reply to thread Export thread (mbox)