~chrisppy/beagles-discuss

2 2

Error building with go 1.15

Details
Message ID
<CA2ZLTAI3YNW.3NTHUUKD9H3VT@amestris>
DKIM signature
pass
Download raw message
Thanks for Beagles, been enjoying using it.

Just wanted to share this error I've encountered building the project:

```
➜  beagles git:(main) make
go build   -ldflags="-X 'main.Version=0.2.0'"  -o beagles
../../go/pkg/mod/git.sr.ht/~adnano/go-gemini@v0.1.22/fs.go:8:2: package io/fs is not in GOROOT (/usr/lib/golang/src/io/fs)
make: *** [Makefile:22: beagles] Error 1
```

I think this has to do with the gemini package. Looks like others have
encountered something similar in other packages, too, e.g.

https://github.com/golang-migrate/migrate/issues/480

```
➜  beagles git:(main) go version
go version go1.15.8 linux/amd64
```

Best,
Nate
Details
Message ID
<CA35U9CWDRRA.RSV7YLCVTA60@archer>
In-Reply-To
<CA2ZLTAI3YNW.3NTHUUKD9H3VT@amestris> (view parent)
DKIM signature
pass
Download raw message
Nate,

Sorry about that, I had actually moved the minimum go version to 1.16,
but I had forgotten to reflect that in both the README and CHANGELOG.
Are you able to move to the newer Go version to resolve the build error
you are seeing?

Thanks,
Chris
Details
Message ID
<CA365APMQS9F.PSIJU0EP77IL@amestris>
In-Reply-To
<CA35U9CWDRRA.RSV7YLCVTA60@archer> (view parent)
DKIM signature
fail
Download raw message
DKIM signature: fail
> Sorry about that, I had actually moved the minimum go version to 1.16,
> but I had forgotten to reflect that in both the README and CHANGELOG.
> Are you able to move to the newer Go version to resolve the build error
> you are seeing?

Thanks for getting back to me, and for Beagles! No worries at all.  I'm
using the go toolchain from the Fedora 33 stock repository, which is
1.15. I imagine it'll get an upgrade with the release of Fedora 34 in a
few weeks, and I can wait until then to update to the latest bits (I
don't do enough go programming to want to maintain my own version of the
toolchain).

Best,
Nate
Reply to thread Export thread (mbox)