~eliasnaur/gio

Go 1.16 heads-up

Details
Message ID
<CANtNKfqu9vri8SgnSxeR_zyO3Rg25SLTi1bh6g--vLqsT+Zq4g@mail.gmail.com>
DKIM signature
pass
Download raw message
While discussing a PR to add Windows compute shaders with Elias in
https://github.com/gioui/gio/pull/14. One of the problems was that a
generated shaders.go is getting out of hand (in the PR ~800kb). It
would be much nicer to use //go:embed, however that will require
bumping minimum required Go version to 1.16. It’ll take some time
before all the parts for Windows get added, so there’s still time to
upgrade your local/test environments and voice your concerns.

tl;dr; sometime in the future, Go 1.16 will be minimum required version for Gio.
Reply to thread Export thread (mbox)