~jmbwell

Recent activity

Testing move-to; URI missing in alsoKnownAs 10 months ago

From John Burwell to ~tsileo/microblog.pub-devel

I am testing moving from a microblog.pub instance to a Mastodon
instance, and I am not able to proceed past an error that the new
instance does not have the old instance's URI in alsoKnownAs. For
example:

```
root@microblog:~/microblog.pub# make account=jmbwell@interrobang.pizza move-to
docker run --rm --volume `pwd`/data:/app/data --volume `pwd`/app/static:/app/app/static microblogpub/microblogpub inv move-to jmbwell@interrobang.pizza
Initiating move to @jmbwell@interrobang.pizza
@jmbwell@interrobang.pizza/https://interrobang.pizza/users/jmbwell is missing https://jmbwell.me in alsoKnownAs
```

The destination is a Mastodon instance. Mastodon allows me to add 
jmbwell@jmbwell.me as an alias. It does not allow me to put

Re: Troubleshooting inv 1 year, 5 months ago

From John Burwell to ~tsileo/microblog.pub-devel

Very helpful, thank you!

The task that is soaking the CPU is `inv process-incoming-activities`.

In uvicorn.log, I'm seeing repeated "database is locked" errors when trying to 
insert incoming activity into the db.

I don't see any errors in the log immediately preceding the first occurrence of the 
"database is locked" error. It looks like it's all just normal ActivityPub CREATE
operations. 

I've checked with `lsof` and `fuser` to see whether something else might be accessing the
microblog.db file, and nothing shows up. I shut down the container and did an `sqlite3 
microblogpub.db "pragma integrity_check;"`, which returned "ok". I ran

Troubleshooting inv 1 year, 5 months ago

From John Burwell to ~tsileo/microblog.pub-devel

I feel like I need to find out what inv is doing. How can I get it to show me activity or error messages?

For the past few hours, I'm getting no incoming or outgoing activity, my stream is not up to date, and attempts to post or delete or follow (anything sending outgoing activity) results in an Internal Server Error. I notice that 'inv' is soaking up my CPU.

I am running the docker image. If I run docker-compose up, I see log messages from the supervisor but nothing else. 

I've rebooted, and I've run git pull/make build/docker-compose down/docker-compose up, so I should be on HEAD.

Any guidance for seeing what's happening would be appreciated!

Support for separate domains for handle and web? 1 year, 6 months ago

From John Burwell to ~tsileo/microblog.pub-devel

With microblog.pub, can I set a handle at a base domain, as in @john@example.com, but host the instance (and webfinger and static assets, etc.) at a subdomain like microblog.example.com?

I have a domain I'd like to use, but I don't necessarily want microblog to be the one and only service available at the base domain.

Thank you!