Stuttgart, Germany


Recent activity

Re: How to build imrsh? 6 days ago

From Max Schillinger to ~emersion/mrsh-dev

 > Should be fixed with module3, can't be bothered to do anything to fix
 > compilation before that's merged.

What's module3? Is there a not yet merged patch for that?

 >  It's probably a symlink or other
 > non-normal file somewhere, but you should read the relevant part of
 > hare/module/scan.ha to verify that

The type assertion happens in type_for_ext call with the argument
"/home/max/repos/mrsh/mrsh" (the mrsh executable).

To check this I have added the following line to

Re: [PATCH rc] interp: catch path:error 6 days ago

From Max Schillinger to ~sircmpwn/hare-dev

> It's better to catch that error when initializing the buffer:

Fine for me. I'm a Hare beginner and I just wanted to get it work somehow.

Re: How to build imrsh? 7 days ago

From Max Schillinger to ~emersion/mrsh-dev

 > https://git.d2evs.net/~ecs/imrsh should just work so long as you have
libmrsh installed. Also note that upstream mrsh isn't particularly
maintained either, so ymmv

Thank you. I'm trying ~ecs/imrsh now. `haredo run` fails:

$ LD_LIBRARY_PATH=/usr/local/lib haredo run
haredo run
haredo   all
Abort: ./hare/module/scan.ha:345:4: type assertion failed
/media/home/max/repos/imrsh/all.do: line 2:  8263 Aborted
  (core dumped) LD=cc $HARE build -o imrsh -lmrsh
haredo   all (error: exited with status 134)

[PATCH] haredo.ha: pipe_flag is pipe_flags now 7 days ago

From Max Schillinger to ~autumnull/haredo-devel

Signed-off-by: Max Schillinger <maxschillinger@web.de>
 src/haredo.ha | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/haredo.ha b/src/haredo.ha
index 036bf4f..8f6d6f9 100644
--- a/src/haredo.ha
+++ b/src/haredo.ha
@@ -62,7 +62,7 @@ export fn main() void = {
	// a slot is acquired, and writing a byte to the pipe when a slot is freed.
	let (rd, wr) = match (os::getenv("HAREDO_PIPE")) {
	case void =>
		yield unix::pipe(unix::pipe_flag::NOCLOEXEC)!;
[message trimmed]

How to build imrsh? 8 days ago

From Max Schillinger to ~emersion/mrsh-dev

Hi all,

I'm trying to compile imrsh. I could build mrsh using `./configure`,
`make` and `sudo make install`.

When I ran `meson build` in the imrsh folder, I got

     Run-time dependency mrsh found: NO (tried pkgconfig and cmake)

Next I tried `PKG_CONFIG_PATH=/usr/local/lib/pkgconfig meson build`:

The Meson build system
Version: 1.1.0

[PATCH rc] interp: catch path:error 9 days ago

From Max Schillinger to ~sircmpwn/hare-dev

Signed-off-by: Max Schillinger <maxschillinger@web.de>
 interp/path.ha | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/interp/path.ha b/interp/path.ha
index afe0caa..c1b5033 100644
--- a/interp/path.ha
+++ b/interp/path.ha
@@ -28,6 +28,13 @@ export fn resolve(cmd: str) (io::file | fs::error) = {
			yield s;

		const buf = match (buf) {
[message trimmed]

[PATCH hare.vim] compiler: update error format 12 days ago

From Max Schillinger to ~sircmpwn/hare-dev

`:make` did not work. I guess, the output of `hare build` has changed
and this plugin is not up to date.

Signed-off-by: Max Schillinger <maxschillinger@web.de>
 compiler/hare.vim | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/compiler/hare.vim b/compiler/hare.vim
index 0930b04..068930a 100644
--- a/compiler/hare.vim
+++ b/compiler/hare.vim
@@ -22,8 +22,8 @@ else
[message trimmed]

[PATCH] [PATCH sxmo-utils] Add device profile for Nexus 5 (battery device) 1 year, 10 months ago

From Max Schillinger to ~mil/sxmo-devel

 scripts/deviceprofiles/sxmo_deviceprofile_hammerheadqcom.sh | 5 +++++
 1 file changed, 5 insertions(+)
 create mode 100644 scripts/deviceprofiles/sxmo_deviceprofile_hammerheadqcom.sh

diff --git a/scripts/deviceprofiles/sxmo_deviceprofile_hammerheadqcom.sh b/scripts/deviceprofiles/sxmo_deviceprofile_hammerheadqcom.sh
new file mode 100644
index 0000000..805599e
--- /dev/null
+++ b/scripts/deviceprofiles/sxmo_deviceprofile_hammerheadqcom.sh
@@ -0,0 +1,5 @@

# Nexus 5
[message trimmed]