~nfraprado

São Paulo, Brazil

https://nfraprado.net

~nfraprado/test

Last active 1 year, 6 months ago
View more

Recent activity

Re: [PATCH] iio: ad7266: convert probe to full device-managed 4 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

On Wed, Apr 06, 2022 at 11:51:24AM -0300, Maíra Canal wrote:
> Convert probe functions to device-managed variants, with exception of
> the regulator, which required a devm_add_action_or_reset() hook
> registration.
> 
> ---
> Estou apenas fazendo alguns testes da minha configuração de email, pois, por
> algum motivo, os meus emails não estão aparecendo na lista do kernel.
> 
> Eu creio que o meu email não está indo para lista, porque o email do Michel
> Hennerich não é válido. Estou apenas testando essa hipótese antes de mandar para 
> a lista do kernel novamente.
> 
> Novamente, desculpa o spam na lista

Re: [PATCH v3 2/2] drm: selftests: convert drm_cmdline_parser selftest to KUnit 6 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Maira,

thanks for the patch. Please see the feedback below.

On Wed, Feb 02, 2022 at 09:03:00PM -0300, Leandro Ribeiro wrote:
> 
> 
> 
> -------- Forwarded Message --------
> Subject: Fwd: [PATCH v3 2/2] drm: selftests: convert drm_cmdline_parser
> selftest to KUnit
> Date: Wed, 2 Feb 2022 20:55:36 -0300
> From: Maíra Canal <maira.canal@usp.br>
> To: leandrohr@riseup.net

Re: [PATCH v3 1/2] drm: selftests: refactor drm_cmdline_parser 6 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Maira,

thanks for the patch.

To be quite honest with you, I have a feeling that this change won't be accepted
upstream. I know that seeing how much duplicated code there are in these tests
gives an itch to create helper functions that de-duplicate it. I feel it as
well.

However, it seems to me that these helper functions end up just making the test
harder to follow. Here you have written the helper functions with very few
parameters, which makes them even shorter (less typing and code duplication),
however it makes a lot of assumptions, and for this reason they aren't very
re-usable.

Re: [PATCH v3 1/9] drm: vkms: Replace the deprecated drm_mode_config_init 8 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Igor,

just some nits on the commit message.

On Mon, Nov 22, 2021 at 04:43:52PM -0300, Igor Torrente wrote:
> The `drm_mode_config_init` was deprecated since c3b790e commit, and it's

When referring to other commits, it's best to write it as 'commit <12-digit-SHA>
("description")' [1]. Also, imperative mood works best, so my suggestion would
be:

`drm_mode_config_init` is deprecated since commit c3b790ea07a1 ("drm: Manage
drm_mode_config_init with drmm_") in favor of `drmm_mode_config_init`. Update
the former to the latter.

Re: [PATCH] drm: selftest: convert drm_plane_helper selftest to KUnit 8 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Anderson,

thank you for the patch.

See comments below.

On Sat, Nov 20, 2021 at 10:38:47PM +0900, Anderson Fraga wrote:
> test-drm_plane_helper.c is a unit test for plane_helper.c to check the
> support of primary plane implementation on top of the normal CRTC
> configuration interface. It also checks plane updates in the switch
> process to the atomic helper infrastructure.

I think you don't need to explain what this test is about, since the change here
is only about the framework used.

DRM KUnit hackathon 10 months ago

From Nícolas F. R. A. Prado to ~lkcamp/discussion

Hello,

We belong to a student group, LKCAMP [1], which is focused on sharing kernel and
free software development knowledge and mentoring newcomers to become
contributors to these projects.

As part of our efforts, we'll be organizing a hackathon to convert the drm
selftests in drivers/gpu/drm/selftests/ (and possibly the ones in
drivers/dma-buf too) to the KUnit framework. It will take place on October 30.

So please expect to receive some patches from our mentees on that date. It
probably won't be a big volume (experience tells it'll be around half a dozen
patches). We'll also make sure to do an internal review beforehand to catch
common first-timer mistakes and teach the basics.

Re: [PATCH v2] lib: use of kunit in test_parman.c 11 months ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hello,

Any update on the review of this patch? Jiri Pirko?

Thanks,
Nícolas

On Wed, Jul 28, 2021 at 02:31:07PM +0800, David Gow wrote:
> On Wed, Jul 28, 2021 at 12:55 PM José Aquiles Guedes de Rezende
> <jjoseaquiless@gmail.com> wrote:
> >
> > Convert the parman test module to use the KUnit test framework.
> > This makes the test clearer by leveraging KUnit's assertion macros
> > and test case definitions,as well as helps standardize on a testing framework.

Re: [PATCH v2] lib: use of kunit in test_parman.c 1 year, 20 days ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Oi Aquiles,

respondendo em português mesmo e só internamente na nossa lista de emails.

Eu vi que você já recebeu vários reviews e até já mandou esse v2, bem legal! :D

Um detalhe é que você não colocou a lista do KUnit em cópia:
kunit-dev@googlegroups.com

Não precisa reenviar só por isso, claro, só estou falando pra você lembrar de
adicionar na v3 caso pedirem pra alterar mais alguma coisa :).

Outra coisa, essas tags que os revisores colocam, quando você reenvia uma nova
versão do patch, você tem que adicionar no seu commit, depois dos

Re: [PATCH v4] lib: use of kunit in test_parman.c 1 year, 22 days ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Aquiles,

On Tue, Jul 20, 2021 at 08:16:15PM -0300, José Aquiles Guedes de Rezende wrote:
> Convert the parman test module to use the KUnit test framework.
> This makes thetest clearer by leveraging KUnit's assertion macros
> and test case definitions,as well as helps standardize on a testing framework.
> 
> Co-developed-by: Matheus Henrique de Souza Silva <matheushenriquedesouzasilva@protonmail.com>
> Signed-off-by: Matheus Henrique de Souza Silva <matheushenriquedesouzasilva@protonmail.com>
> Signed-off-by: José Aquiles Guedes de Rezende <jjoseaquiless@gmail.com>
> ---
> 
> Changes in v2:
> - Format according checkpatch.pl

Re: [PATCH v3] lib: use of kunit in test_parman.c 1 year, 29 days ago

From Nícolas F. R. A. Prado to ~lkcamp/patches

Hi Aquiles,

On Fri, Jul 16, 2021 at 10:39:57PM -0300, José Aquiles Guedes de Rezende wrote:
> Convert the parman test module to use the KUnit test framework.
> This makes thetest clearer by leveraging KUnit's assertion macros
> and test case definitions,as well as helps standardize on a testing framework.
> 
> Co-developed-by: Matheus Henrique de Souza Silva <matheushenriquedesouzasilva@protonmail.com>
> Signed-off-by: Matheus Henrique de Souza Silva <matheushenriquedesouzasilva@protonmail.com>
> Signed-off-by: José Aquiles Guedes de Rezende <jjoseaquiless@gmail.com>
> ---
> 
> Changes in v2:
> - Format according checkpatch.pl