Last active 9 months ago
View more

Recent activity

[PATCH git.sr.ht] Resolve name and email from mailmap 26 days ago

From Sebastian to ~sircmpwn/sr.ht-dev

The mailmap file is consulted to obtain the canonical name/email of an
author or committer of a commit, or a tagger of a tag.

Signed-off-by: Sebastian <sebastian@sebsite.pw>
For a demonstration, https://git.sr.ht/~sebsite/gitsrhttest and
https://git.sebsite.pw/~sebastian/gitsrhttest contain the same repo, but
the latter Sourcehut instance has this patch applied.

 gitsrht/blueprints/api/porcelain.py | 14 ++++++++------
 gitsrht/blueprints/repo.py          |  4 ++--
 gitsrht/git.py                      | 15 ++++++++++++++-
 gitsrht/rss.py                      |  5 +++--
 gitsrht/templates/blame.html        |  7 ++++---
[message trimmed]

Re: Issues hosting minimal git.sr.ht instance 26 days ago

From Sebastian to ~sircmpwn/sr.ht-discuss

Ah, yup, that was the issue. Thanks!

Issues hosting minimal git.sr.ht instance 27 days ago

From Sebastian to ~sircmpwn/sr.ht-discuss

Hi! I'm trying to host git.sr.ht (for the purpose of
hacking/contributing), but I'm having issues with requests to /query and
/oauth2 (for meta.sr.ht) not working. I'm on Arch Linux, currently just
using the official meta.sr.ht and git.sr.ht packages. The nginx config
(using meta.sebsite.pw and git.sebsite.pw as the domain names) is nearly
identical to the example on https://man.sr.ht/configuration.md.

Here's my config.ini (private stuff redacted):

    site-blurb=the facker's horge

[PATCH hare] haredoc: resolve symbols in root namespace a month ago

From Sebastian to ~sircmpwn/hare-dev

Fixes: https://todo.sr.ht/~sircmpwn/hare/555
Signed-off-by: Sebastian <sebastian@sebsite.pw>
 cmd/haredoc/main.ha | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/cmd/haredoc/main.ha b/cmd/haredoc/main.ha
index efc1442e..d7683caf 100644
--- a/cmd/haredoc/main.ha
+++ b/cmd/haredoc/main.ha
@@ -123,14 +123,14 @@ export fn main() void = {

	let decl = "";
[message trimmed]

Re: [PATCH harec v2] check: only allow exprs which mutate scope in compound/for a month ago

From Sebastian to ~sircmpwn/hare-dev

Sorry, accidentally sent the message early before it was done. I meant to 
say it was originally called mutable_scope, which I think makes more 
sense for ctx, but do you have any other ideas?

Re: [PATCH harec v2] check: only allow exprs which mutate scope in compound/for a month ago

From Sebastian to ~sircmpwn/hare-dev

Oct 23, 2022 13:25:29 Bor Grošelj Simić <bgs@turminal.net>:
> +1 to keeping the `mutable` bool in `ctx`, but it'd be great if it can 
> be
> given a better name.

It was originally named mutable_scope

Re: [PATCH harec v2] check: disallow autofilling fields without default values a month ago

From Sebastian to ~sircmpwn/hare-dev

This should apply once my "tests: style" patch is applied.

[PATCH harec v2] check: disallow autofilling fields without default values a month ago

From Sebastian to ~sircmpwn/hare-dev

Closes: https://todo.sr.ht/~sircmpwn/hare/531
Signed-off-by: Sebastian <sebastian@sebsite.pw>
Since v1: add link to ticket in TODO comment and add more tests

The corresponding patch to hare should be applied first to avoid
breakage (crossing my fingers it doesn't need to be rebased). Although
the spec is unchanged, this is still a large change since a lot of Hare
code relied on all struct fields being zeroed, even if the default value
wasn't defined by the spec.

The one part of this that still isn't implemented is that structs with
overlapping fields should have undefined default values, which currently
isn't checked for (see the TODO comment).
[message trimmed]

[PATCH harec v4] Add -a flag to set target architecture a month ago

From Sebastian to ~sircmpwn/hare-dev

This is needed in harec since the size and alignment of types is used in
check, and some types have sizes and alignments which depend on the
target architecture.

Signed-off-by: Sebastian <sebastian@sebsite.pw>
Since v3: give valist a different size depending on target architecture

Since there's now a distinction between the three currently supported
architectures, builtin_types_init has three different branches, though
they all only differ by one line. My rationale for this is that when
more architectures are added, it will be cleaner avoid any nesting for
architectures which share the sizes/alignments for certain types. Please
let me know if you think this is the wrong call, and the function should
[message trimmed]

[PATCH hare] all: don't autofill fields without a default value a month ago

From Sebastian to ~sircmpwn/hare-dev

Signed-off-by: Sebastian <sebastian@sebsite.pw>
From my local testing, there haven't been any issues with this. However,
since a lot of the changed code is in crypto::*, some more eyes making
sure that everything behaves as expected may be warranted.

 bufio/buffered.ha         | 24 ++++++++++++----------
 crypto/chacha/chacha20.ha |  2 ++
 crypto/cipher/ctr.ha      |  3 ++-
 crypto/cipher/gcm.ha      | 13 +++++++-----
 crypto/salsa/salsa20.ha   |  2 ++
 encoding/pem/pem.ha       | 11 +++++-----
 format/tar/reader.ha      | 42 +++++++++++++++++++++++++--------------
 hare/unit/context.ha      |  2 +-
[message trimmed]