~sircmpwn/hare-dev

This thread contains a patchset. You're looking at the original emails, but you may wish to use the patch review UI. Review patch
7 5

[PATCH hare] cmd/hare: Use LDLINKFLAGS instead of LDFLAGS

Details
Message ID
<20230203174425.21479-1-contact+sr.ht@hacktivis.me>
DKIM signature
missing
Download raw message
Patch: +2 -2
From: "Haelwenn (lanodan) Monnier" <contact@hacktivis.me>

Implements: https://todo.sr.ht/~sircmpwn/hare/784
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
---
 cmd/hare/schedule.ha | 2 +-
 docs/hare.scd        | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/cmd/hare/schedule.ha b/cmd/hare/schedule.ha
index 643a80e9..f082f5aa 100644
--- a/cmd/hare/schedule.ha
+++ b/cmd/hare/schedule.ha
@@ -40,7 +40,7 @@ fn getenv(var: str) []str = {
// (executable name, executable variable, flags variable)
type tool = (str, str, str);

let ld_tool: tool = ("", "LD", "LDFLAGS");
let ld_tool: tool = ("", "LD", "LDLINKFLAGS");
let as_tool: tool = ("", "AS", "ASFLAGS");
let ar_tool: tool = ("", "AR", "ARFLAGS");
let qbe_tool: tool = ("qbe", "QBE", "QBEFLAGS");
diff --git a/docs/hare.scd b/docs/hare.scd
index ba23eb25..9e08a4cc 100644
--- a/docs/hare.scd
+++ b/docs/hare.scd
@@ -297,7 +297,7 @@ The following environment variables affect *hare*'s execution:
:  Additional flags to pass to *as*(1).
|  *LD*
:  Name of the *ld*(1) command to use.
|  *LDFLAGS*
|  *LDLINKFLAGS*
:  Additional flags to pass to *ld*(1).

# SEE ALSO
-- 
2.39.1

[hare/patches] build success

builds.sr.ht <builds@sr.ht>
Details
Message ID
<CQ947NL64DUD.3L1TWDVG0X9XS@cirno2>
In-Reply-To
<20230203174425.21479-1-contact+sr.ht@hacktivis.me> (view parent)
DKIM signature
missing
Download raw message
hare/patches: SUCCESS in 3m40s

[cmd/hare: Use LDLINKFLAGS instead of LDFLAGS][0] from [Haelwenn (lanodan) Monnier][1]

[0]: https://lists.sr.ht/~sircmpwn/hare-dev/patches/38694
[1]: contact+sr.ht@hacktivis.me

✓ #933864 SUCCESS hare/patches/alpine.yml  https://builds.sr.ht/~sircmpwn/job/933864
✓ #933865 SUCCESS hare/patches/freebsd.yml https://builds.sr.ht/~sircmpwn/job/933865
Details
Message ID
<CQ94MP73F00B.2WM5PKJ1TKXCH@debian>
In-Reply-To
<20230203174425.21479-1-contact+sr.ht@hacktivis.me> (view parent)
DKIM signature
missing
Download raw message
On Fri Feb 3, 2023 at 11:44 AM CST, Haelwenn (lanodan) Monnier wrote:
> From: "Haelwenn (lanodan) Monnier" <contact@hacktivis.me>
>
> Implements: https://todo.sr.ht/~sircmpwn/hare/784
> Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
> ---
>  cmd/hare/schedule.ha | 2 +-
>  docs/hare.scd        | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/cmd/hare/schedule.ha b/cmd/hare/schedule.ha
> index 643a80e9..f082f5aa 100644
> --- a/cmd/hare/schedule.ha
> +++ b/cmd/hare/schedule.ha
> @@ -40,7 +40,7 @@ fn getenv(var: str) []str = {
>  // (executable name, executable variable, flags variable)
>  type tool = (str, str, str);
>  
> -let ld_tool: tool = ("", "LD", "LDFLAGS");
> +let ld_tool: tool = ("", "LD", "LDLINKFLAGS");
>  let as_tool: tool = ("", "AS", "ASFLAGS");
>  let ar_tool: tool = ("", "AR", "ARFLAGS");
>  let qbe_tool: tool = ("qbe", "QBE", "QBEFLAGS");
> diff --git a/docs/hare.scd b/docs/hare.scd
> index ba23eb25..9e08a4cc 100644
> --- a/docs/hare.scd
> +++ b/docs/hare.scd
> @@ -297,7 +297,7 @@ The following environment variables affect *hare*'s execution:
>  :  Additional flags to pass to *as*(1).
>  |  *LD*
>  :  Name of the *ld*(1) command to use.
> -|  *LDFLAGS*
> +|  *LDLINKFLAGS*
>  :  Additional flags to pass to *ld*(1).
>  
>  # SEE ALSO
> -- 
> 2.39.1

The LD and LINK parts in LDLINKFLAGS is redundant.

If this is going to be hare specific, why don't call it HARELDFLAGS
instead?
Details
Message ID
<CQ94RLTD4EW7.1NV1748FJCIH5@eiger>
In-Reply-To
<CQ94MP73F00B.2WM5PKJ1TKXCH@debian> (view parent)
DKIM signature
missing
Download raw message
On Fri Feb 3, 2023 at 6:07 PM UTC, Jose Lombera wrote:
> The LD and LINK parts in LDLINKFLAGS is redundant.
>
> If this is going to be hare specific, why don't call it HARELDFLAGS
> instead?

The goal isn't to be Hare-specific, it's to not conflict with C's usage
of $LDFLAGS (passing it into $CC). Another option that was floated was
$LD_LDFLAGS, but I prefer $LDLINKFLAGS. None of these options are great,
but I don't think there's anything better and I'd rather avoid
bikeshedding.
Details
Message ID
<CQ953NG6TPF1.1MNMWJ378F5MM@debian>
In-Reply-To
<CQ94RLTD4EW7.1NV1748FJCIH5@eiger> (view parent)
DKIM signature
missing
Download raw message
On Fri Feb 3, 2023 at 12:14 PM CST, Ember Sawady wrote:
> On Fri Feb 3, 2023 at 6:07 PM UTC, Jose Lombera wrote:
> > The LD and LINK parts in LDLINKFLAGS is redundant.
> >
> > If this is going to be hare specific, why don't call it HARELDFLAGS
> > instead?
>
> The goal isn't to be Hare-specific, it's to not conflict with C's usage
> of $LDFLAGS (passing it into $CC). Another option that was floated was
> $LD_LDFLAGS, but I prefer $LDLINKFLAGS. None of these options are great,
> but I don't think there's anything better and I'd rather avoid
> bikeshedding.

Maybe it's not the objective to be Hare-specific, but in practice it
will be.  No other software will use this variable (and if it does,
we'll have to worry with clashes again).  I'm not interested in
bikeshedding either, and have no strong opinions on this, I was just
pointing this out.
Details
Message ID
<CQ954LRH6UFO.2KVGGLJ9BX8NN@eiger>
In-Reply-To
<CQ953NG6TPF1.1MNMWJ378F5MM@debian> (view parent)
DKIM signature
missing
Download raw message
On Fri Feb 3, 2023 at 6:29 PM UTC, Jose Lombera wrote:
> Maybe it's not the objective to be Hare-specific, but in practice it
> will be.  No other software will use this variable (and if it does,
> we'll have to worry with clashes again).

I think it makes sense to try to standardize an environment variable
that's just passed directly to $LD
Details
Message ID
<Y91UmGaJc2V6C0at@cloudsdale.the-delta.net.eu.org>
In-Reply-To
<CQ954LRH6UFO.2KVGGLJ9BX8NN@eiger> (view parent)
DKIM signature
missing
Download raw message
[2023-02-03 18:31:11+0000] Ember Sawady:
>On Fri Feb 3, 2023 at 6:29 PM UTC, Jose Lombera wrote:
>> Maybe it's not the objective to be Hare-specific, but in practice it
>> will be.  No other software will use this variable (and if it does,
>> we'll have to worry with clashes again).
>
>I think it makes sense to try to standardize an environment variable
>that's just passed directly to $LD

Agreed and I think I'd rather have `HARE_LDFLAGS` later on if need be,
LDFLAGS being erroneously shoved to CC isn't an issue only with Hare but also Perl,
among probably a lot of other software out there.
Details
Message ID
<CS0LOVRI57Y7.1TSN3CIDVL1JI@taiga>
In-Reply-To
<20230203174425.21479-1-contact+sr.ht@hacktivis.me> (view parent)
DKIM signature
missing
Download raw message
Thanks!

To git@git.sr.ht:~sircmpwn/hare
   772ec67d..b76e834c  master -> master
Reply to thread Export thread (mbox)