~sircmpwn/sr.ht-dev

man.sr.ht: Preparations for PEP440 support v1 APPLIED

Conrad Hoffmann: 1
 Preparations for PEP440 support

 1 files changed, 43 insertions(+), 0 deletions(-)
#1229927 alpine.yml failed
Export patchset (mbox)
How do I use this?

Copy & paste the following snippet into your terminal to import this patchset into git:

curl -s https://lists.sr.ht/~sircmpwn/sr.ht-dev/patches/52907/mbox | git am -3
Learn more about email & git

[PATCH man.sr.ht] Preparations for PEP440 support Export this patch

Currrently, builds for patches are broken because the version numbers
generated for them are not valid according to PEP 440 [1].

This has to be solved in several steps, in coordination with the
packaging code. Procedure will be the same as for core.sr.ht:

https://git.sr.ht/~sircmpwn/core.sr.ht/commit/57ee3427

The only difference is that the extra build step (running `make`) will
remain in `setup.py` (as there is no generic mechanism for this in
`pyproject.toml`). This just means the build process will still always
have to be performed with setuptools as backend.

[1] https://peps.python.org/pep-0440
---
 pyproject.toml | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)
 create mode 100644 pyproject.toml

diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..23bcf8c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,43 @@
[build-system]
requires = ["setuptools", "setuptools_scm"]
build-backend = "setuptools.build_meta"

[project]
name = "mansrht"
dynamic = ["version"]
description = "man.sr.ht website"
readme = "README.md"
authors = [{name = "Drew DeVault", email = "sir@cmpwn.com"}]
dependencies = [
    "srht",
]
license.text = "AGPL-3.0-only"

[project.urls]
repository = "https://git.sr.ht/~sircmpwn/man.sr.ht"

[tool.setuptools]
# This defaults to true, but we explicitly specify what we want included in the
# package via packages and tool.setuptools.package-data below.
include-package-data = false
packages = [
    "mansrht",
    "mansrht.alembic",
    "mansrht.alembic.versions",
    "mansrht.blueprints",
    "mansrht.static",
    "mansrht.static.icons",
    "mansrht.templates",
    "mansrht.types",
]
script-files = [
    "mansrht-initdb",
    "mansrht-migrate",
]
[tool.setuptools.package-data]
"mansrht" = ['default_query.graphql', 'schema.graphqls']
"mansrht.templates" = ['*.html']
"mansrht.static" = ['*']
"mansrht.static.icons" = ['*']

[tool.setuptools_scm]
-- 
2.45.1
Thanks!

To git@git.sr.ht:~sircmpwn/man.sr.ht
   8540644..e0febde  master -> master
man.sr.ht/patches/alpine.yml: FAILED in 1m2s

[Preparations for PEP440 support][0] from [Conrad Hoffmann][1]

[0]: https://lists.sr.ht/~sircmpwn/sr.ht-dev/patches/52907
[1]: mailto:ch@bitfehler.net

✗ #1229927 FAILED man.sr.ht/patches/alpine.yml https://builds.sr.ht/~sircmpwn/job/1229927