~sircmpwn/sr.ht-packages

sr.ht-pkgbuilds: remove python-pystache v1 PROPOSED

Roshless: 2
 remove python-pystache
 bump python-pgpy version

 6 files changed, 14 insertions(+), 36 deletions(-)
Export patchset (mbox)
How do I use this?

Copy & paste the following snippet into your terminal to import this patchset into git:

curl -s https://lists.sr.ht/~sircmpwn/sr.ht-packages/patches/15352/mbox | git am -3
Learn more about email & git
View this thread in the archives

[PATCH sr.ht-pkgbuilds 1/2] remove python-pystache Export this patch

packaged already in community repository
---
 python-pystache/PKGBUILD | 22 ----------------------
 1 file changed, 22 deletions(-)
 delete mode 100644 python-pystache/PKGBUILD

diff --git a/python-pystache/PKGBUILD b/python-pystache/PKGBUILD
deleted file mode 100644
index d362ebc..0000000
--- a/python-pystache/PKGBUILD
@@ -1,22 +0,0 @@
# Contributor: Florian Klink <flokli at flokli dot de>

_python=python
_distname=pystache
pkgname=$_python-$_distname
pkgver=0.5.4
pkgrel=3
pkgdesc="The mustache template engine written in python"
arch=(any)
url="http://github.com/defunkt/pystache"
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
provides=('python-pystache')
conflicts=('python-pystache')
source=( "https://pypi.python.org/packages/source/${_distname:0:1}/$_distname/$_distname-$pkgver.tar.gz")
md5sums=('485885e67a0f6411d5252e69b20a35ca')

package() {
  cd "$srcdir/$_distname-$pkgver"
  $_python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || exit 1
}
-- 
2.29.2

[PATCH sr.ht-pkgbuilds 2/2] bump python-pgpy version Export this patch

bump python-stripe version

bump python-weasyprint version

bump python-minio version

bump python-emailthreads version
---
 python-emailthreads/PKGBUILD |  4 ++--
 python-minio/PKGBUILD        |  6 +++---
 python-pgpy/PKGBUILD         | 10 +++++-----
 python-stripe/PKGBUILD       |  4 ++--
 python-weasyprint/PKGBUILD   |  4 ++--
 5 files changed, 14 insertions(+), 14 deletions(-)

diff --git a/python-emailthreads/PKGBUILD b/python-emailthreads/PKGBUILD
index 0f113f5..cf639c1 100644
--- a/python-emailthreads/PKGBUILD
+++ b/python-emailthreads/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=python-emailthreads
_pkgname=emailthreads
pkgver=0.1.0
pkgver=0.1.3
pkgrel=1
pkgdesc='Python library to parse and format email threads'
arch=(any)
@@ -9,7 +9,7 @@ url=https://github.com/emersion/python-emailthreads
license=('MIT')
makedepends=(python-setuptools)
source=(https://github.com/emersion/${pkgname}/archive/v${pkgver}.tar.gz)
sha256sums=('62fd111d4298331d5fae5b9c6e56aa860966ffdb1b453ace5990a143e437b4c5')
sha256sums=('c315384b3f674c2b53acbe0a7a40326e26cf9b7efdc2721356bc9ba5f4f001d9')

build() {
  cd ${srcdir}/${pkgname}-${pkgver}
diff --git a/python-minio/PKGBUILD b/python-minio/PKGBUILD
index 062589b..c02fc37 100644
--- a/python-minio/PKGBUILD
+++ b/python-minio/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=python-minio
_pkgname=minio
pkgver=5.0.6
pkgrel=2
pkgver=5.0.10
pkgrel=1
pkgdesc='MinIO Python Library for Amazon S3 Compatible Cloud Storage'
arch=(any)
url=https://pypi.org/project/minio/
@@ -10,7 +10,7 @@ license=('Apache 2.0')
depends=("python-certifi")
makedepends=(python-setuptools)
source=($pkgname-$pkgver.tar.gz::https://github.com/minio/minio-py/archive/$pkgver.tar.gz)
sha256sums=('d935b6edf163e52479bc0ddbb5a44a5ee38bf5cda59b5289db02aa37b610e79d')
sha256sums=('22bc9e200368b6155aecf00697e4aed4dda9c7a5fb002741b8b64177a558187e')

build() {
  cd ${srcdir}/minio-py-${pkgver}
diff --git a/python-pgpy/PKGBUILD b/python-pgpy/PKGBUILD
index 4a66533..b3acc74 100644
--- a/python-pgpy/PKGBUILD
+++ b/python-pgpy/PKGBUILD
@@ -3,7 +3,7 @@

pkgbase=python-pgpy
pkgname=('python-pgpy' 'python2-pgpy')
pkgver=0.4.3
pkgver=0.5.3
pkgrel=1
pkgdesc="Pretty Good Privacy for Python - a pure Python OpenPGP implementation."
arch=('any')
@@ -11,10 +11,10 @@ license=('BSD')
url="https://github.com/SecurityInnovation/PGPy"
makedepends=('python-setuptools' 'python-cryptography' 'python-six' 'python-pyasn1'
             'python2-setuptools' 'python2-cryptography' 'python2-enum34' 'python2-singledispatch' 'python2-six' 'python2-pyasn1')
source=("https://github.com/SecurityInnovation/PGPy/releases/download/${pkgver}/PGPy-${pkgver}.tar.gz")
sha256sums=('04412dddd6882ac0c5d5daf4326c28d481421851a68e25e7ac8e06cc9dc2b902')
sha384sums=('e67cf964dbde17b01a5656275a3825f0357ea01a8d0b1032f04f67af603922f264a811a041ba7529876725c280e563b2')
sha512sums=('fd0ccd5d619e96d1aefbe99fed4d634140ba14d2faff228b6e2aaf60b3c157f46c2f1d06955dc4b0bfe4ef511ce5f66a328121ef4f7563496c66461924e51eb6')
source=("https://github.com/SecurityInnovation/PGPy/releases/download/v${pkgver}/PGPy-${pkgver}.tar.gz")
sha256sums=('a49c269cedcaf82ac6999bcae5fd3f543ecb1c759f9d48a15ad8d8fa4ac03987')
sha384sums=('6e60f5f8e6125299c84e0e0ec70642f65b21eb43818b251314f824bb18f522ce05b94525af9a2b366c5832b0580ca7ea')
sha512sums=('5f27292af764164dc15cd491a297c4a41b3ce9c56e50cd8c71da05b4a886d402d530674592db8e8ea02f323d760342d9d69bfeb88e6109c4345bd701ee285587')

prepare() {
    cp -a PGPy-${pkgver}{,-python2}
diff --git a/python-stripe/PKGBUILD b/python-stripe/PKGBUILD
index cd6da05..1f618fb 100644
--- a/python-stripe/PKGBUILD
+++ b/python-stripe/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dylan Whichard <dylan@whichard.com>
_name=stripe
pkgname=python-stripe
pkgver=2.40.0
pkgver=2.55.0
pkgrel=1
pkgdesc='Stripe python bindings'
arch=('any')
@@ -10,7 +10,7 @@ license=('MIT')
depends=('python>=3.0')
makedepends=('python-setuptools')
source=("https://pypi.python.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
md5sums=('6a7b4211ce65d5863df113b3f58f47e9')
md5sums=('4f09ce2d2cc92abe4d5ad641dbf1b5a2')

package() {
	cd "$srcdir/$_name-$pkgver"
diff --git a/python-weasyprint/PKGBUILD b/python-weasyprint/PKGBUILD
index d9f9f4a..8ba6e57 100644
--- a/python-weasyprint/PKGBUILD
+++ b/python-weasyprint/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Florijan Hamzic <florijanh at gmail dot com>
_pypi_name='WeasyPrint'
pkgver=0.42.3
pkgver=52.1
pkgrel=3
pkgdesc="Converts web documents (HTML, CSS, SVG, ...) to PDF."
license=('BSD')
@@ -15,7 +15,7 @@ depends=('python' 'pango>=1.29.3' 'gdk-pixbuf2>=2.25' 'python-gobject'
pkgname="python-weasyprint"
_pypi_name_inital=$(echo ${_pypi_name}|cut -c1)
source=("https://github.com/Kozea/WeasyPrint/archive/v${pkgver}.tar.gz")
md5sums=('9995077586ef379ae5574d7ba2a12fc3')
md5sums=('ce418e63309d9abb62111f68322f5e46')


package() {
-- 
2.29.2