~smfrgsn

Recent activity

Re: Replying to emails: always added as a recipient. 14 days ago

From Sam Ferguson to ~rjarry/aerc-discuss

Thanks Bence - appreciate it.

Adding the aliases line in accounts.conf resolved the recipient issue.

And upgrading to the latest master solved the address-book-cmd issue.





Sam Ferguson

On Fri, Nov 25, 2022 at 6:06 PM Bence Ferdinandy <bence@ferdinandy.com> wrote:
>

Re: Issues with address tab-completion 15 days ago

From Sam Ferguson to ~rjarry/aerc-discuss

To follow this up - Based on the error message it looks as if the
string that's being passed to the address book command might be
incorrect or not escaped/quoted correctly when it is passed to the
address-book-cmd .

If the string in the To: line is
John Smith <John.Smith@microsoft.com>,

The error message is
could not complete header: read completions: grep: Smith: No such file
or directory
Indicating that grep is probably looking for "john" inside a 'Smith' file.

In fact it shouldn't be passing anything from the completed address to

Re: Issues with address tab-completion 15 days ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi -

I'm also getting some problematic behaviour with address-cmd completion.

My setup is the following:
address-book-cmd=grep -F -i -- "%s"
"/Users/106445/.local/share/maildir2addr/addrs.tsv"
I've followed the instructions at: https://github.com/BourgeoisBear/maildir2addr

I can get the completion to work on a fresh compose window for the
first address I add, but for the second (or if I try to delete the
first address) it seems to hang possibly (because it is trying to
search for "" and loading everything in the .tsv file). If I reply to
an email and try to delete an email address, I can't get completion

Replying to emails: always added as a recipient. 15 days ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi Everyone -

Every time I reply to an email my address is included as a recipient.
I have to delete my address by going up to the address line and
finding my address, and then deleting it, which is slow.

It doesn't seem to be affected by this setting:

# Allow to address yourself when replying
#
# Default: true
reply-to-self=false

I'm on aerc 0.13.0 (go1.19.2 arm64 darwin).

Re: Microsoft Office 365 Authenication a month ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi Robert and Jason,

I'm also using the mbsync based approach for my university O365 email
(thanks to Jason) as they restricted the use of azure AD, and stopped
supporting LOGIN authentication. I'm looking forward to switching over
to the xoauth2 direct authentication that was recently added to aerc
(thanks aerc developers) as soon as possible but I'm not quite clear
on the exact way to input the accounts.conf credentials. I'm sure I
can work it out soon.

Since we are talking O365 with other O365 people - can I check whether
my current problem is just due to weird behaviour from O365? If I'm
replying to an email in aerc and key r-q to quote the email and reply
to all recipients, my name is added to the 'To:' line.  I _think_ this

Re: Office 365 Authentication 3 months ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi All -

Excited to say that with Jason's instructions I have got mbsync to
authenticate with xoauth2 and sync my office365 email. I'm then using
aerc's maildir support to read the mail directories.

Briefly, I had to :
1) install cyrus-sasl with homebrew, then
2) download and compile the sasl xoauth2 plugin from source, then
3) move the plugin into the correct folder in the homebrew tree, and
test with 'pluginviewer'
4) install mbsync with home-brew
5) alter the brew formula to get mbsync to point to the homebrew sasl2
installation as you can't load plugins into /usr/bin ..., and rebuild

Office 365 Authentication 3 months ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi Everyone -

Just an update on my efforts to log into Office365 email with aerc.

My university has restricted access to App Registrations in Azure
Active Directory, as well as App Passwords in the Office Portal
Security Information page in My Account. The vast majority of
documented methods to authenticate to Office365 require an App
Registration and then use the credentials in a script. I've tried a
few of them to no avail as I can't get the credentials. I've also
tried using powershell to create an app registration with no success.

I've looked at using a notmuch/mbsync backend, but office365
authentication problems appear to exist for mbsync as well.

Re: Microsoft removed basic authentication 3 months ago

From Sam Ferguson to ~rjarry/aerc-discuss

Thanks everyone for your detailed comments. Rene - wow - thanks - that
is a big how to.

To make things even more complicated our uni uses Okta for 2 factor
authentication.

I tried the microsoft app passwords link, and got stuck in an infinite
authentication loop - looks like I might not be allowed to do that.
I'm going to look further into the Azure option - it might be possible
even though its difficult to see if I have access and I think I have
to subscribe.

On my travels I came across this method for alpine from purdue university:
https://www.purdue.edu/science/scienceit/mfa-alpine.html

Microsoft removed basic authentication 4 months ago

From Sam Ferguson to ~rjarry/aerc-discuss

Hi All -

I used to connect to my University's office365 instance with the
'login' method, but about 6 weeks back I received an email saying that
Microsoft was removing basic authentication. Since then I've been
unable to use aerc - and just when I was getting really excited about
calendar invite acceptances! I found using aerc made work email
delightful (not an easy task), and so now I find myself really missing
it.

I've tried a bunch of how-tos posted online, but there isn't much info
out there about how to authenticate aerc using oauth for office365
specifically. I have it set up for my personal gmail using an
app-specific password - but I don't get much workload there. I've seen