~trylletre

Recent activity

[wlopm] monitor configuration is lost after toggle 4 months ago

From alice to ~leon_plickat/public-inbox

My monitor has the following modes preferred at the top:

 Available modes:
   2560x1440 @ 59.940 Hz
   2560x1440 @ 169.831 Hz
   [snip]

Of course, I set it to `mode 2560x1440@170Hz` in sway.

When doing `wlopm --toggle DP-1`, upon it being enabled again, the top mode is
picked instead of the configured higher-refresh-rate one.

wlr-randr 0.4.0 exhibited the same behaviour. In 0.4.1, it was fixed, with the
fix being

Re: [PATCH soju] contrib: add docker buildfile 5 months ago

From alice to ~emersion/soju-dev

On Mon Jan 29, 2024 at 6:36 AM UTC, Moritz Poldrack wrote:
> From: Moritz Poldrack <git@moritz.sh>
>
> Signed-off-by: Moritz Poldrack <git@moritz.sh>
> ---
>
> As suggested by f_ on IRC
>
>  contrib/docker/Dockerfile         | 11 +++++++++++
>  contrib/docker/docker-compose.yml | 11 +++++++++++
>  2 files changed, 22 insertions(+)
>  create mode 100644 contrib/docker/Dockerfile
>  create mode 100644 contrib/docker/docker-compose.yml
>

Re: Unsubscribe 10 months ago

From alice to ~sircmpwn/alpine-devel

On Wed Sep 20, 2023 at 2:32 AM UTC, Jonathan Aquilina wrote:
> How can I unsubscribe from this list please.

if you look at the email headers of an email in the list you can see
List-Unsubscribe: <mailto:~alpine/devel+unsubscribe@lists.alpinelinux.org?subject=unsubscribe>

most gui clients show this under some drop down menu after parsing the header,
but all you have to do is email that.

somebody already told you this the last time you asked.

> Also please ensure you have a footer in the list emails so a user can easily
> unsubscribe themselves.

Re: IPv6 DNS in docker.io/alpine 1 year, 1 month ago

From alice to ~sircmpwn/alpine-devel

On Fri Jun 16, 2023 at 12:33 PM CEST, caskd wrote:
> Hello everyone,
>
> i've been trying to pin down where the resolv.conf in the docker image
> is coming from without success. I've been looking into submitting a request
> to add IPv6 addresses to the default too to allow containers with IPv6 only
> connectivity to resolve without deriving a image from the base.
>
> Could you help me pin down where the build scripts/Dockerfile for these are
> and would adding IPv6 as a fallback cause problems?

isn't the resolv.conf in a started container populated on start depending on the
networking configuration?

Re: Issue with ACF and lua 1 year, 1 month ago

From alice to ~sircmpwn/alpine-devel

On Sat Jun 3, 2023 at 9:47 AM CEST, Daniele Colì wrote:
> Thank you Guys!
>
> I tried to downgrade the lua-subprocess using the package from the v3.17 
> branch 
> (http://mirror.fit.cvut.cz/alpine/v3.17/main/aarch64/lua-subprocess-0.0.20141229-r4.apk), 
> but the issue remains.
>
> I'll wait for the build...

that sounds like a different issue entirely then, and not related to the version
of that package at all.

Re: Issue with ACF and lua 1 year, 1 month ago

From alice to ~sircmpwn/alpine-devel

On Fri Jun 2, 2023 at 8:13 PM CEST, Daniele Colì wrote:
> Hi Team,
>
> I recently upgraded my linux box (RaspberryPi) and started having issues 
> with the ACF web pages. Most information are missing or reported as unknown.
>
> Any suggestion?

there was(is) a broken dependency of lua-subprocess-0_git20160421,
0_git20141229 would be fixed (apk upgrade -a), but the ARM builders are
currently offline so it doesn't exist yet.

once they're back just running `apk upgrade -a` should fix it

Re: enabling FANOTIFY in alpine 1 year, 3 months ago

From alice to ~sircmpwn/alpine-devel

On Thu Apr 6, 2023 at 11:49 AM CEST, cyber psych wrote:
> Didn't notice that, thanks @alice

for future reference, since you might want to know how to find if a running
kernel has something enabled:

 $ doas modprobe configs
 $ zcat /proc/config.gz | grep CONFIG_FAN
 CONFIG_FANOTIFY=y
 CONFIG_FANOTIFY_ACCESS_PERMISSIONS=y

this will correspond to the currently running kernel configuration.

Re: enabling FANOTIFY in alpine 1 year, 3 months ago

From alice to ~sircmpwn/alpine-devel

On Thu Apr 6, 2023 at 11:09 AM CEST, cyber psych wrote:
> Hi all,
>
> I want to enable FANOTIFY in alpine linux VM, I see it's disabled by
> default. A few articles suggested I can enable this and build a custom
> kernel, is there any other way to enable this on a running VM, without
> building kernel?

it is already enabled in linux-lts and linux-virt, in edge and 3.17.

>
> I tried searching for linux kernel modules which can be enabled on runtime,
> but couldn't find one.
>

Re: [Vulnerability] CVE-2023-0464 1 year, 3 months ago

From alice to ~sircmpwn/alpine-devel

On Mon Apr 3, 2023 at 1:07 PM CEST, Haidar Deenmahomed (Proximity-Paris) wrote:
>
> Hello,
>
> I am writing to bring to your attention a security vulnerability that was
> identified while running Jfrog Scan on a docker image based on Alpine 3.17. The

"based on" implies "nothing to do with us", as it's not just the "base image".
the 3.17.3 image has this fixed already.

> scan highlighted CVE-2023-0464, which has the potential to create a denial-of-
> service (DoS) attack on affected systems.

it was fixed in openssl 3.0.8-r1, https://security.alpinelinux.org/vuln/CVE-2023-0464,

Re: [PATCH soju 1/1] Add certbot instructions. 1 year, 4 months ago

From alice to ~emersion/soju-dev

On Fri Mar 24, 2023 at 4:41 PM CET, ~martylake wrote:
> From: neogaldr <neogaldr@gmail.com>
>
> ---
>  contrib/certbot.md | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>  create mode 100644 contrib/certbot.md
>
> diff --git a/contrib/certbot.md b/contrib/certbot.md
> new file mode 100644
> index 0000000..e386a49
> --- /dev/null
> +++ b/contrib/certbot.md
> @@ -0,0 +1,21 @@